Multimedia & Games   3D Graphics   Other Graphics   Misc   Blog   About   CV

Blog

Aug 10, 2011

I just upgraded from Firefox 3 to 5 and find that my blog is shown without a stylesheet at all. It still works fine in Firefox 3, and latest Chrome and Safari and I assume other browsers too. And the rest of my site still works fine in Firefox 5 too; it's only the blog part that's broken.

Update: It appears it was the stylesheet that was not recognized. I had my stylesheet inside an .asp file to be able to execute server-side code in it. That has always worked just fine but it appears to break when the browser is Firefox 5 AND the site linking to the stylesheet is on Google's Blogger service. When the same stylesheet is linked to from the part of my website that's hosted on my own server, it works fine. The stylesheet is hosted on my own server in both cases, so how it can make any difference where the html page is hosted I do not understand. In either case, baking the stylesheet into a static .css file and linking to that instead seems to have fixed the problem.

Labels:

Posted by Rune Skovbo Johansen at 7:48 PM

Share:
2 Comments:

  At August 10, 2011 at 8:24 PM , OpenID st4rdog said...

The first thing I see is that there is some duplicated code in the head section.

Such as the section starting "http://runevision.com/include/styles.css.asp".

That wouldn't cause problems on its own, but there must be other stuff happening around those sections. I don't have an HTML editor installed right now to look.

  At September 2, 2011 at 4:03 PM , Anonymous Anonymous said...

We didn't mind. Programmers' blogs are never beautiful, so it makes no significant difference if CSS doesn't render correctly. :D

Post a Comment
Subscribe to Post Comments [Atom]
Links to this post:

Create a Link

Back to rune|vision blog front page
Blog